<!DOCTYPE html>
<html>
<head>
  <!--[if IE]><![endif]-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="http://www.csnne.com/sites/csnne/files/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="tp:EnableExternalController" content="true" />
<link rel="amphtml" href="http://www.csnne.com/boston-red-sox/drellich-boston-red-sox-should-get-trade-done-sooner-rather-later?amp" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-57x57-precomposed.png" rel="apple-touch-icon-precomposed" sizes="57x57" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-57x57.png" rel="apple-touch-icon" sizes="57x57" />
<meta name="description" content="The time to get a deal done is now if the Boston Red Sox want to make a splash before the trade deadline — if the price is palatable" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-72x72.png" rel="apple-touch-icon" sizes="72x72" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-72x72-precomposed.png" rel="apple-touch-icon-precomposed" sizes="72x72" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-114x114.png" rel="apple-touch-icon" sizes="114x114" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-114x114-precomposed.png" rel="apple-touch-icon-precomposed" sizes="114x114" />
<meta name="abstract" content="The time to get a deal done is now if the Boston Red Sox want to make a splash before the trade deadline — if the price is palatable" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-120x120-precomposed.png" rel="apple-touch-icon-precomposed" sizes="120x120" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-120x120.png" rel="apple-touch-icon" sizes="120x120" />
<meta name="keywords" content="Boston Red Sox, Evan Drellich, Dave Dombrowski, John Farrell" />
<meta name="robots" content="follow, index" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-144x144-precomposed.png" rel="apple-touch-icon-precomposed" sizes="144x144" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-144x144.png" rel="apple-touch-icon" sizes="144x144" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-152x152.png" rel="apple-touch-icon" sizes="152x152" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-152x152-precomposed.png" rel="apple-touch-icon-precomposed" sizes="152x152" />
<meta name="news_keywords" content="Boston Red Sox, Evan Drellich, Dave Dombrowski, John Farrell" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-180x180-precomposed.png" rel="apple-touch-icon-precomposed" sizes="180x180" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-180x180.png" rel="apple-touch-icon" sizes="180x180" />
<meta name="rating" content="general" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="image_src" href="http://www.csnne.com/sites/csnne/files/2017/07/18/red_sox_dave_dombrowski_071717.jpg" />
<link rel="canonical" href="http://www.csnne.com/boston-red-sox/drellich-boston-red-sox-should-get-trade-done-sooner-rather-later" />
<meta property="og:site_name" content="CSNNE.com" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Drellich: Red Sox should get a trade done sooner rather than later" />
<meta property="og:url" content="http://www.csnne.com/boston-red-sox/drellich-boston-red-sox-should-get-trade-done-sooner-rather-later" />
<meta property="og:description" content="The time to get a deal done is now if the Red Sox want to make a splash before the trade deadline — if the price is palatable" />
<meta property="og:updated_time" content="2017-07-18T01:52:16-04:00" />
<meta property="og:image" content="http://www.csnne.com/sites/csnne/files/2017/07/18/red_sox_dave_dombrowski_071717.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@csnne" />
<meta name="twitter:url" content="http://www.csnne.com/boston-red-sox/drellich-boston-red-sox-should-get-trade-done-sooner-rather-later" />
<meta name="twitter:title" content="Drellich: Red Sox should get a trade done sooner rather than later" />
<meta name="twitter:description" content="The time to get a deal done is now if the Red Sox want to make a splash before the trade deadline — if the price is palatable" />
<meta name="twitter:image" content="http://www.csnne.com/sites/csnne/files/2017/07/18/red_sox_dave_dombrowski_071717.jpg" />
<meta property="article:author" content="https://www.facebook.com/drellich/" />
<meta property="article:published_time" content="2017-07-18T00:36:36-04:00" />
<meta property="article:modified_time" content="2017-07-18T01:52:16-04:00" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
  <meta name=viewport content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=no">
  <title>Evan Drellich: Boston Red Sox should get a trade done sooner rather than later</title>
  <!-- Don't remove this. We are loading base file at first -->
  <style id="base-css">html{font-family:sans-serif;-ms-text-size-adjust:100%;-webkit-text-size-adjust:100%}body{margin:0}article,aside,details,figcaption,figure,footer,header,main,nav,section,summary{display:block}audio,canvas,progress,video{display:inline-block;vertical-align:baseline}audio:not([controls]){display:none;height:0}[hidden],template{display:none}a{background:transparent}a:active,a:hover{outline:0}abbr[title]{border-bottom:1px dotted}b,strong{font-weight:bold}dfn{font-style:italic}h1{font-size:2em;margin:0.67em 0}mark{background:#ff0;color:#000}small{font-size:80%}sub,sup{font-size:75%;line-height:0;position:relative;vertical-align:baseline}sup{top:-0.5em}sub{bottom:-0.25em}img{border:0}svg:not(:root){overflow:hidden}figure{margin:1em 40px}hr{box-sizing:content-box;height:0}pre{overflow:auto}code,kbd,pre,samp{font-family:monospace, monospace;font-size:1em}button,input,optgroup,select,textarea{color:inherit;font:inherit;margin:0}button{overflow:visible}button,select{text-transform:none}button,html input[type="button"],input[type="reset"],input[type="submit"]{-webkit-appearance:button;cursor:pointer}button[disabled],html input[disabled]{cursor:default}button::-moz-focus-inner,input::-moz-focus-inner{border:0;padding:0}input{line-height:normal}input[type="checkbox"],input[type="radio"]{box-sizing:border-box;padding:0}input[type="number"]::-webkit-inner-spin-button,input[type="number"]::-webkit-outer-spin-button{height:auto}input[type="search"]{-webkit-appearance:textfield;box-sizing:content-box}input[type="search"]::-webkit-search-cancel-button,input[type="search"]::-webkit-search-decoration{-webkit-appearance:none}fieldset{border:1px solid #c0c0c0;margin:0 2px;padding:0.35em 0.625em 0.75em}legend{border:0;padding:0}textarea{overflow:auto}optgroup{font-weight:bold}table{border-collapse:collapse;border-spacing:0}td,th{padding:0}html{font-family:Arial, Helvetica, sans-serif}a{text-decoration:none}h1,.alpha,h2,.beta,h3,.gamma,h4,.delta,h5,.epsilon,h6,.zeta{font-family:Arial, Helvetica, sans-serif;text-transform:uppercase}h1 a,h1 a:visited,.alpha a,.alpha a:visited,h2 a,h2 a:visited,.beta a,.beta a:visited,h3 a,h3 a:visited,.gamma a,.gamma a:visited,h4 a,h4 a:visited,.delta a,.delta a:visited,h5 a,h5 a:visited,.epsilon a,.epsilon a:visited,h6 a,h6 a:visited,.zeta a,.zeta a:visited{text-decoration:none}h1,.alpha{font-family:"BebasNeue", Arial, Helvetica, sans-serif;font-size:40px;font-size:2.5rem;font-weight:400}h2,.beta{font-size:34px;font-size:2.125rem}h3,.gamma{font-size:21px;font-size:1.312rem}h4,.delta{font-size:18px;font-size:1.125rem}h5,.epsilon{font-size:16px;font-size:1rem}h6,.zeta{font-size:16px;font-size:1rem}p{margin:0 0 1em}blockquote{padding:0 1.5em;font-style:italic}blockquote p{margin:0}q{font-style:italic}mark,.marker{padding:0.1em 0.5em;background:#666;color:#fff;font-size:12px;font-size:0.75rem;text-transform:capitalize}::-webkit-input-placeholder{color:#fff}:-moz-placeholder{color:#fff;opacity:1}::-moz-placeholder{color:#fff;opacity:1}:-ms-input-placeholder{color:#fff}img{max-width:100%;height:auto;vertical-align:top}.media-box iframe{width:100%;height:auto}@media (min-width: 1260px){.desktop-large_hidden {display: none !important;}.desktop-large_visible{display: block !important;}}@media (min-width: 1024px) and (max-width: 1260px){.desktop-small_hidden{display: none !important;}.desktop-small_visible{display: block !important;}}@media (min-width: 320px) and (max-width: 767px){.mobile_hidden{display:none !important}.mobile_visible{display:block !important}}@media (min-width: 768px) and (max-width: 1023px){.tablet_hidden{display:none !important}.tablet_visible{display:block !important}}</style>
  <link type="text/css" rel="stylesheet" href="//www.csnne.com/sites/csnne/files/css/css_dg3HikB6EEryHhgflQcQKZAw7C9W5Hk2djQwr6RX4as.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnne.com/sites/csnne/files/css/css_H204bpbVjF86qI4gLE4nUiZN54Jv6GVT80B-Cq_vNrM.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnne.com/sites/csnne/files/css/css_HoD_aTLaZeY20JCgJtTJAHaUQnMQv_tHSWaWc38cMAE.css" media="all" />
  <!-- Script for catch errors on Js error testing.
       It should goes before Drupal scripts array and any placed script -->
  <script>
    window.jsErrors = [];
    window.onerror = function(errorMessage) {
      window.jsErrors[window.jsErrors.length] = errorMessage;
    };
  </script>
  <script type="text/javascript" src="http://www.csnne.com/sites/csnne/files/js/js_62gSTH2bzFWOOS74mfIFKr-NFsdDVqAFE0eav6P1DXs.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var mpscall = {"site":"rsn-web","path":"\/node\/707291","title":"Drellich: Red Sox should get a trade done sooner rather than later","qs":"cD15YTVuYmNzJm9jaWQ9eWFob28meXB0cj15YWhvbz9zcmM9cnNz","content_id":"node707291","is_content":"1","type":"article","cag":{"author":"Evan-Drellich","league":"MLB","section":"Boston-Red-Sox","sport":"Baseball","tags":"Boston-Red-Sox|Dave-Dombrowski|Todd-Frazier","team":"Boston-Red-Sox","field-videos":"What-is-the-Red-Sox-biggest-need-before-the-trade-deadline"},"pubdate":"1500352596"}
var mpsopts = {"host":"mps.nbcuni.com","updatecorrelator":"1"}
var mps=mps||{};mps._ext=mps._ext||{};mps._adsheld=[];mps._queue=mps._queue||{};mps._queue.gptloaded=mps._queue.gptloaded||[];mps.__timer=Date.now();mps.__intcode="v2"; "function"!=typeof mps.getAd&&(mps.getAd=function(a){if("string"!=typeof a)return!1;var b="mps-getad-"+a.replace(/\W/g,"");mps._ext&&mps._ext.loaded||(mps._queue.gptloaded.push(function(){"function"==typeof mps._gptfirst&&mps._gptfirst();mps.insertAd("#"+b,a)}),mps._adsheld.push(a));return'<div id="'+b+'" class="mps-wrapper" data-mps-fill-slot="'+a+'"></div>'});(function(){head=document.head||document.getElementsByTagName("head")[0];mpsload=document.createElement("script");mpsload.src="//"+mpsopts.host+"/fetch/ext/load-"+mpscall.site+".js?nowrite=2";mpsload.id="mps-load";head.insertBefore(mpsload,head.firstChild)})();
//--><!]]>
</script>
<script type="text/javascript" src="http://www.csnne.com/sites/csnne/files/js/js_N6JkNedF3eKzTB4U2z7d6_hOZh4KH5IcCJ48oUPMMP0.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.createElement( "picture" );
//--><!]]>
</script>
<script type="text/javascript" src="http://www.csnne.com/sites/csnne/files/js/js_7-q4xx5FaXgFWWma9tMCS9Q__822jcg6rhczPisS8LQ.js"></script>
<script type="text/javascript" src="http://www.csnne.com/sites/csnne/files/js/js_vMF5ceuq9dIMCp51JmaNRuy-VwSfV9q97hEuYH7GTsc.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'), document.getElementsByTagName('script')[0], 'http://cdn.taboola.com/libtrc/nbcsports-csnne/loader.js');
//--><!]]>
</script>
<script type="text/javascript" src="http://www.csnne.com/sites/csnne/files/js/js_yYf4YNLLu9ELo-DF_7H8n01bEKnLypPXzGbqmsGvZdw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.__gigyaConf = {"enabledProviders":"*","sessionExpiration":2000000,"connectWithoutLoginBehavior":"loginExistingUser"}
//--><!]]>
</script>
<script type="text/javascript" src="http://cdn.gigya.com/JS/socialize.js?apikey=2_lBXsng05eQvHLrSWLB-ONCKSvHw9E0k-eBLKRIHC9F6LpP6GzyZu7lw38UxeMK8E&amp;lang=en"></script>
<script type="text/javascript" src="http://www.csnne.com/sites/csnne/files/js/js_Z1Z5PKpBdbRSfZy58aQZCobPEg6qd_WSO885ekbF36s.js"></script>
<script type="text/javascript" src="http://www.csnne.com/sites/csnne/files/js/js_r60blgZiI7v1ySDERaqfg1QrKzzcytHfxhivgXsSUIg.js"></script>
<script type="text/javascript">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</script>
</head>
<body class="html not-front not-logged-in page-node page-node- page-node-707291 node-type-article rsn-site rsn-site-csnne has-two-sidebars" >
    
  <header id="nbcsports-fixed-header">

    <!-- start Primary Nav -->
    <nav id="nbcsports-primary-nav">
                  <a href="http://www.csnne.com" id="home-page-link"></a>  <a href="http://www.csnne.com/boston-celtics" class="dynamic-nav-link" data-tid="236">Celtics</a>  <a href="http://www.csnne.com/new-england-patriots" class="dynamic-nav-link" data-tid="221">Patriots</a>  <a href="http://www.csnne.com/boston-red-sox" class="dynamic-nav-link" data-tid="191">Red Sox</a>  <a href="http://www.csnne.com/boston-bruins" class="dynamic-nav-link" data-tid="206">Bruins</a>  <a href="http://www.csnne.com/new-england-revolution" class="dynamic-nav-link" data-tid="251">Revolution</a>  <a href="http://www.csnne.com/golf" class="dynamic-nav-link" data-tid="161">Golf</a>  <a href="http://www.csnne.com/video" class="dynamic-nav-link" data-tid="126">Video</a>  <a href="http://www.csnne.com/podcast" class="dynamic-nav-link">Podcast</a>  <a href="http://www.csnne.com/csn-staff-0" class="dynamic-nav-link">Staff</a>  <a href="http://shop.nbcsports.com/pages/CSN_NE/partnerid/13746" class="dynamic-nav-link">Shop</a>  <a href="http://www.csnne.com/alerts" class="dynamic-nav-link">Alerts</a>  <a href="http://www.csnne.com/contests" class="dynamic-nav-link">Contests</a>  <a href="http://www.csnne.com/2017-wnba-connecticut-sun-schedule" class="dynamic-nav-link">CT SUN (WNBA)</a>
<span id="more-nav-btn" class="no-select no-more-links" unselectable="on" tabindex="0">MORE</span>
    </nav>
    <!-- end Primary Nav -->

    <!-- start More Nav -->
    <nav id="more-nav" class="no-more-links">
    </nav>
    <!-- end More Nav -->

    <!-- start Secondary Nav -->
    <nav id="nbcsports-secondary-nav">
        
<div class="nbcsports-secondary-nav__wrapper">

        <a href="http://www.csnne.com/video/category/381">Video</a>        <a href="http://www.csnne.com/podcast/thebaseballshow">Podcast</a>        <a href="http://stats.csnne.com/mlb/standings.asp">Standings</a>        <a href="http://stats.csnne.com/mlb/teamstats.asp?team=02&amp;type=schedule">Schedule</a>        <a href="http://stats.csnne.com/mlb/teamstats.asp?team=02&amp;type=stats">Stats</a>        <a href="https://www.aceticket.com/boston-red-sox-tickets">Tickets</a>        <a href="http://www.comcastsportsnet.com/" class="rsn-local-nav">Comcast SportsNet</a>        <a href="http://www.golfchannel.com/" class="golf-channel-nav">Golf Channel</a>        <a href="http://www.rotoworld.com/" class="rotoworld-nav">Rotoworld</a>  
  <div id="nbcsports-search-box">
    <form action="http://www.csnne.com/search" class="search-form" method="get" autocomplete="off">
      <span class="icon"></span>
      <label>Search</label>
      <input type="search" name="search_api_views_fulltext" id="nbcsports-search" placeholder="Search CSN New England" tabindex="0"/>
    </form>
  </div>

</div>
    </nav>
    <!-- end Secondary Nav -->

  </header>
  <!-- end #nbcsports-fixed-header -->

  <div id="wrapper">
    <div id="outer">
      <!-- Start leaderboard -->
      <div id="nbcsports-leaderboard">
                    <div class="region region-top-region">
    <div id="block-bean-dx-agency-facebook-pixel" class="block block-bean block-bean-custom-block block-type-custom-block block-type-custom-block-single">

    
  <div class="content">
    <div class="entity entity-bean bean-custom-block clearfix">

  <div class="content">
    <div class="field field-name-field-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '901737133246109'); // Insert your pixel ID here.
fbq('track', 'PageView');
fbq('track', 'ViewContent');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=901737133246109&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code --></div></div></div>  </div>
</div>
  </div>
</div>
<div id="block-mps-topbanner" class="block block-mps">

    
  <div class="content">
    <div id="topbanner"><script>typeof(mps)=='object' && typeof(mps.getAd)=='function' && document.write(mps.getAd('topbanner'));</script></div>  </div>
</div>
  </div>
              </div>
      <!-- End leaderboard -->

      <!-- Start scoreboard -->
              <div id="nbcsports-scoreboard">
            <div class="region region-scoreboard">
    <div class="scoreboard with_ad">
  <iframe id="scoreboard-ticker" src="http://csnnewengland.stats.com/score_ticker/index.html?sports=LOCAL%7CMLB%7CNFL%7CNBA%7CNHL%7CMLS%7CCFB%7CCBK%7CGOLF%7CNASCAR%7CFORM1%7CEPL%7CCYCLING"></iframe>
</div>
<div id="block-mps-scorelogo" class="block block-mps">

    
  <div class="content">
    <div id="scorelogo"><script>typeof(mps)=='object' && typeof(mps.getAd)=='function' && document.write(mps.getAd('scorelogo'));</script></div>  </div>
</div>
  </div>
        </div>
            <!-- Start scoreboard -->

      <!-- Start content wrapper -->
      <div id="nbcsports-content-wrapper">

        <aside id="nbcsports-live-extra-widget">
                        <div class="region region-left-rail">
    <div id="block-nbcs-live-extra-nbcs-live-extra" class="block block-nbcs-live-extra">

    
  <div class="content">
    <div class="live-extra-widget" v-cloak>
  <a href="http://www.csnne.com/live" class="link link_type-block">
    <div class=""></div>
  </a>

  <header class="title live-extra-widget__title">
    <a href="http://www.csnne.com/live" class="link link_type-block live-extra-widget__watch-now"><span class="title-text">Watch now</span></a>
    <a href="http://www.csnne.com/live" class="link link_type-block live-extra-widget__full-link">View full schedule</a>
  </header>

  <div class="live-extra-widget__scrollbox">
    <div class="live-extra-widget__events" id="lew-touch-events">
      <div v-if="events.live.length" class="events-list live-extra-widget__events-list live-extra-widget__events-list_type-live">
        <div class="title events-list__title events-list__title_type-live">Live</div>
        <ul class="list events-list__list">
          <live-extra-widget-event v-for="event in events.live" :event="event" :key="event.id"></live-extra-widget-event>
        </ul>
      </div>
      <div v-if="events.upcoming.length" class="events-list live-extra-widget__events-list live-extra-widget__events-list_type-upcoming">
        <div class="title events-list__title events-list__title_type-upcoming">
          <span class="title-text">Upcoming Events</span>
        </div>
        <ul class="list events-list__list">
          <live-extra-widget-event v-for="event in events.upcoming" :event="event" :key="event.id"></live-extra-widget-event>
        </ul>
      </div>
      <span v-if="noEvents" class="live-extra-widget__no-events">No Events at this time</span>
    </div>
  </div>
</div>

<script type="x-template" id="live-extra-widget-event">
  <li class="list__item live-extra-widget__event-animate" :class="{ 'event-active': active }" :style="{ animationDelay: 50 * event.index + 'ms' }">
    <div class="live-extra-widget__event">
      <div class="live-extra-widget__event__wrapper">
        <span class="live-extra-widget__event-channel">{{ event.network_display_name }}</span>
        <span class="live-extra-widget__event-name">{{ event.event_title }}</span>
        <span class="live-extra-widget__event-type">{{ event.sport }}</span>
        <span class="live-extra-widget__event-time"><span class="live-extra-widget__event-time__inner">{{ formattedTime }}</span></span>
        <span class="play-btn play-btn_size-small"> </span>
        <a :href="event.destination_url" class="link"></a>
      </div>
    </div>
  </li>
</script>
  </div>
</div>
  </div>
                  </aside>

        <!-- Start main content -->
        <div id="nbcsports-main" class="clearfix">

                      <div class="tabs">
                          </div>
          
          
                      <div id="nbcsports-content-header" class="content-header content-header_full-width">
                <div class="region region-header">
    <div id="block-nbcs-article-nbcs-article-subscription-bar" class="block block-nbcs-article">

    
  <div class="content">
    
<header id="article-nav">
      <div id="article-social-nav">
      <a href="http://www.csnne.com/boston-red-sox" class="blog-name">Boston Red Sox</a>      <span class="blog-social-buttons">
                <span class="social-button-text"></span>
        <span class="blog-social-button-container">
                      <a href="https://www.facebook.com/csnne" class="genericon genericon-facebook" target="_blank"></a>                      <a href="/rss/section/boston-red-sox" class="genericon genericon-feed" target="_blank"></a>                      <a href="/alerts" class="genericon genericon-phone" target="_blank"></a>                      <a href="http://email.comcastsportsnet.com/csn/prefne.do" class="genericon genericon-mail" target="_blank"></a>                      <a href="https://twitter.com/csnne" class="genericon genericon-twitter" target="_blank"></a>                  </span>
              </span>
    </div>
    <!-- #article-social-nav -->
</header>  </div>
</div>
  </div>
            </div>
          
          <div class="main-layout">
            <div class="layout_full-minus-right layout_first dynamic-lede">
              <div class="content-inner">
                                              </div>
            </div>

            <div class="layout_full-minus-right layout_second dynamic-lede">
                <div class="content-inner">
                    <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div class="articles--vod-player-fixed-container"></div>
<div class="articles__wrapper articles__node" data-taxonomy-term="191" data-vocabulary="6" data-active="707291">
  <div class="articles">
    
<article id="post-707291" class="article-module nbcs-article">
      <div class="article-trending-nav-wrapper">
      <ul class="article-trending-nav"><li class="menu-2856 first"><a href="http://twitter.com/evandrellich">Follow Evan Drellich</a></li>
<li class="menu-2851 last"><a href="/podcast/thebaseballshow">Listen to &quot;The Baseball Show&quot; podcast</a></li>
</ul>    </div>
    <div class="article-midbanner" id="midbanner-707291"></div>
  <span id='chrome-data-post-707291' class="hidden" data-chrome='{"league":"mlb","sport":"baseball","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      Drellich: Red Sox should get a trade done sooner rather than later    </h2>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-707291"
         href="http://www.csnne.com/video/what-red-sox-biggest-need-trade-deadline"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/newengland_article/select/media/UMBrjj0bV1cb?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/17/2017-07-17t22-13-46.066z-1280x720.jpg?itok=L4UhyrXN" width="656" height="369" alt="2017-07-17t22-13-46.066z-1280x720.jpg" title="What is the Red Sox biggest need before the trade deadline?" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      Drellich: Red Sox should get a trade done sooner rather than later    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/evan-drellich">Evan Drellich</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnne.com/boston-red-sox/drellich-boston-red-sox-should-get-trade-done-sooner-rather-later"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">July 18, 2017 12:12 AM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-707291" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-707291" id="comments-link-707291" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-707291">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
                        </div>
    <p>BOSTON — Red Sox president of baseball operations Dave Dombrowski should be careful not to discount two things: the impact a trade could have at a time when a team is playing poorly, and the value of having a player for an extra two weeks if acquired, say, today, rather than&nbsp;July 31.</p>
<p>When Dombrowski traded for Drew Pomeranz on July 14, 2016, he acknowledged the latter benefit.</p>
<p>“You get a better pitcher with you at this time, or a better player, it’s helpful,” Dombrowski said last year. “You do have him for a short time, but longer than if you waited until the 31st.</p>
<p>“It’s a situation where you get that advantage. You never know because, does the price go up or does it go down as you get closer to the deadline? Sometimes if you have more supply than demand, you’re in a position, if you wait, sometimes it can be beneficial. Sometimes all of a sudden organizations wait until the very end and they don’t have a place to trade that guy.”</p>
<p>As pointed out elsewhere, there’s <a href="http://www.weei.com/blogs/rob-bradford/are-red-sox-bidding-against-themselves-todd-frazier">not a robust market for third basemen</a> right now among the contenders. Pitching is a different story.</p>
<p>Dealer Dave should try to drive down the price and bargain hunt if he's got the pulse of the third-base market. He’s usually the guy paying top dollar, so it's a commendable endeavor.&nbsp;But only to an extent.&nbsp;</p>
<p>Dombrowski must also consider that a deal is really the one way he can jolt the team, and remember what he spoke of with Pomeranz a year ago — “that advantage” of extra time with a player acquired ahead of the deadline.</p>
<p>John Farrell seems poised to do his part to spark the offense.</p>
<p>The skipper is poised to <a href="http://www.csnne.com/boston-red-sox/john-farrell-open-changing-boston-red-sox-slumping-lineup">shake up the Red Sox lineup</a> ahead of&nbsp;Tuesday&nbsp;night’s game against the Blue Jays, and he should.&nbsp;Realistically, there’s not much else Farrell can do for a lineup that’s been awful to start the second half (and lineup construction always gets more attention than it deserves anyway.)</p>
<p>Trades, though, are no placebo, not if they’re done right. Farrell’s boss has a way to shake things up, as well, and the time to get a deal done is now — if the price is palatable and it doesn't put the team over the luxury tax threshold.&nbsp;</p>
<p>A slightly cheaper price paid in prospects&nbsp;two weeks from now&nbsp;might not be worth the wait.&nbsp;</p>
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/boston-red-sox" rel="tag">Boston Red Sox</a>, <a href="/tags/dave-dombrowski" rel="tag">Dave Dombrowski</a>, <a href="/tags/todd-frazier" rel="tag">Todd Frazier</a></span>
        <div class="comments-container">
              <div id="respond-707291">
          <div id="707291" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-707291"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-707291"></div>
    <div id="taboola-container-text-links-post-707291"></div>
  </footer>
  <!-- .entry-footer -->
</article>

<article id="post-707266" class="article-module nbcs-article">
      <div class="article-trending-nav-wrapper">
      <ul class="article-trending-nav"><li class="menu-2856 first"><a href="http://twitter.com/evandrellich">Follow Evan Drellich</a></li>
<li class="menu-2851 last"><a href="/podcast/thebaseballshow">Listen to &quot;The Baseball Show&quot; podcast</a></li>
</ul>    </div>
    <div class="article-midbanner" id="midbanner-707266"></div>
  <span id='chrome-data-post-707266' class="hidden" data-chrome='{"league":"mlb","sport":"baseball","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      Pearce go-ahead single in eighth leads Blue Jays over Red Sox, 4-3    </h2>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-707266"
         href="http://www.csnne.com/video/drellich-perfect-throw-costs-red-sox-loss"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/newengland_article/select/media/SEe86IDEMpZ8?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/17/2017-07-18t03-03-47.4z-1280x720.jpg?itok=fTbzEPnT" width="656" height="369" alt="2017-07-18t03-03-47.4z-1280x720.jpg" title="Drellich: Perfect throw costs Red Sox in loss" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      Pearce go-ahead single in eighth leads Blue Jays over Red Sox, 4-3    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/associated-press">Associated Press</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnne.com/boston-red-sox/pearce-go-ahead-single-eighth-leads-toronto-blue-jays-over-boston-red-sox-4-3"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">July 17, 2017 11:00 PM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-707266" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-707266" id="comments-link-707266" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-707266">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
          </div>
    <p>BOSTON - Steve Pearce hit a solo homer, then added the go-ahead single in the eighth inning in Toronto's 4-3 victory over the Boston Red Sox on Monday night.</p>
<p>The Blue Jays led 3-0 after two innings but AL East-leading Boston scored three in the seventh, tying it when&nbsp;Dustin Pedroia&nbsp;hit&nbsp;Dominic Leone's only pitch off the Green Monster to tie it. One run scored on the double, and&nbsp;Mookie Betts&nbsp;was thrown out at the plate.</p>
<p>Toronto went back in front in the eighth when Pearce singled to score pinch-runner&nbsp;Ezequiel Carrera&nbsp;from third.</p>
<p>Ryan Tepera&nbsp;(5-1), who started the eighth, was credited with the victory even though Leone was the pitcher of record when the winning run scored. Baseball rule 9.17 (c) instructs the official scorer not to award a victory to a reliever who makes a short, ineffective appearance.</p>
<p>Roberto Osuna&nbsp;pitched the ninth for his 23rd save.</p>
<p>Heath Hembree&nbsp;(1-3) took the loss.</p>
<p>Marcus Stroman&nbsp;took a shutout into the seventh inning for Toronto, allowing three hits - two of them infield hits to the pitcher. But he was also charged with an error for failing to get his foot on the bag when first baseman&nbsp;Justin Smoak&nbsp;fielded&nbsp;Jackie Bradley Jr.'s grounder.</p>
<p>Stroman walked&nbsp;Christian Vazquez&nbsp;to load the bases.&nbsp;Brock Holt's sacrifice fly scored one run and Betts singled in another to chase Stroman.</p>
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/boston-red-sox" rel="tag">Boston Red Sox</a>, <a href="/tags/csnne-newswire" rel="tag">CSNNE Newswire</a>, <a href="/tags/toronto-blue-jays" rel="tag">Toronto Blue Jays</a></span>
        <div class="comments-container">
              <div id="respond-707266">
          <div id="707266" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-707266"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-707266"></div>
    <div id="taboola-container-text-links-post-707266"></div>
  </footer>
  <!-- .entry-footer -->
</article>

<article id="post-707196" class="article-module nbcs-article">
      <div class="article-trending-nav-wrapper">
      <ul class="article-trending-nav"><li class="menu-2856 first"><a href="http://twitter.com/evandrellich">Follow Evan Drellich</a></li>
<li class="menu-2851 last"><a href="/podcast/thebaseballshow">Listen to &quot;The Baseball Show&quot; podcast</a></li>
</ul>    </div>
    <div class="article-midbanner" id="midbanner-707196"></div>
  <span id='chrome-data-post-707196' class="hidden" data-chrome='{"league":"mlb","sport":"baseball","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      Farrell open to changing Red Sox lineup; has already altered rotation    </h2>
              <!-- Image -->
                <div class="image">
            <img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/17/farrell-redsox.jpg?itok=pHUfDU3y" width="656" height="369" alt="farrell-redsox.jpg" title="Farrell open to changing Red Sox lineup; has already altered rotation" />          </div>
                    <!-- end Image -->
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      Farrell open to changing Red Sox lineup; has already altered rotation    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/evan-drellich">Evan Drellich</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnne.com/boston-red-sox/john-farrell-open-changing-boston-red-sox-slumping-lineup"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">July 17, 2017 5:53 PM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-707196" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-707196" id="comments-link-707196" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-707196">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
          </div>
    <p>BOSTON --&nbsp;Sox manager John Farrell is still open to shaking up the Red Sox lineup. Three runs were enough Sunday night behind an excellent David Price, but it’s still been a rough stretch for the Sox of late offensively.</p>
<p>However, the top of the order --&nbsp;Mookie Betts in the leadoff spot, followed by Dustin Pedroia and Xander Bogaerts -- remains the same for Monday night's game against the Blue Jays. They’ve each occupied those slots more than anyone else this season: Betts 65 times, Pedroia 48 times and Bogaerts 60 times.</p>
<p>“Haven’t completely gone away from [the possibility of changing the batting order],” Farrell said. “We have the top three guys, a lot of it is pretty consistent. If you look at the individual matchups against Marcus Stroman here tonight . . . players know what they do against opposing pitchers. And that’s not to say it’s a guarantee for success but I’d like to think guys will come in and say, ‘You know what, I’ve had some success against this guy in the past, let’s take a run with it.’ That’s where we are.”</p>
<p>Against Stroman, Betts is 6-for-19 (.316), Bogaerts 10-for-20 (.500) and Pedroia 7-for-15 (.467).</p>
<p>Moving Betts to a different spot in the lineup -- such as the two- or three-hole, so his first at-bat could come with someone on base -- has been a point of public debate.</p>
<p>“Mookie is not a typical leadoff type of guy,” Farrell said. “Granted, he’s got more power than many other leadoff types, but the ability to get on base, the ability to steal a base, those are parts of the profile that you’d ideally like to get. A little bit of speed to maybe disrupt the defense. But I think over the past probably five, six years, lineup construction has taken a completely different look, where so many teams had looked at the No. 3 spot in the order as your most pivotal. That’s your best hitter.&nbsp;</p>
<p>“A lot of teams now are putting that guy in the two-hole. I’m sure there’s a lot of debate, a lot of sabermetric approach that goes into where you want your so-called best hitter. Bottom line is, you want your guys who get on base the most get to the plate the most often, so you stack the top of your order as best as you can.”</p>
<p>Farrell made clear he wants his on-base guys up top -- that’s his most important criteria. Pedroia leads the team at .385, followed by four players in the .350-range: Bogaerts (.357), Jackie Bradley Jr. (.353), Andrew Benintendi (.352) and Betts (.352).&nbsp;</p>
<p>Benintendi’s had 40 starts in the two-hole.</p>
<p>While Farrell waits on possible lineup alterations, he has altered his rotation so that Chris Sale and David Price get an extra day of rest. Sale, throughout his career, has often pitched on extra rest and the Sox seem to want to keep it that way.</p>
<p>Here’s how it lines up, with seven pitchers in seven days:</p>
<ul>
<li><strong>Monday vs. Toronto</strong>: Eduardo Rodriguez</li>
<li><strong>Tuesday vs. Toronto</strong>: Brian Johnson</li>
<li><strong>Wednesday vs. Toronto</strong>: Drew Pomeranz</li>
<li><strong>Thursday vs. Toronto</strong>: Doug Fister</li>
<li><strong>Friday at Anaheim</strong>: Chris Sale</li>
<li><strong>Saturday at Anaheim</strong>: David Price</li>
<li><strong>Sunday at Anaheim</strong>: Rick Porcello</li>
</ul>
<p>Porcello previously was wedged in between Sale and Price.</p>
<p>“The two most similar [pitchers] might be Eddie and David,” Farrell said. “Just trying to split those two guys up, where Chris has got a different arm slot, different type of stuff, different action on the breaking balls.”</p>
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/boston-red-sox" rel="tag">Boston Red Sox</a>, <a href="/tags/csnne-newswire" rel="tag">CSNNE Newswire</a>, <a href="/tags/dustin-pedroia" rel="tag">Dustin Pedroia</a>, <a href="/tags/john-farrell" rel="tag">John Farrell</a>, <a href="/mookie-betts" rel="tag">Mookie Betts</a>, <a href="/tags/toronto-blue-jays" rel="tag">Toronto Blue Jays</a>, <a href="/tags/xander-bogaerts" rel="tag">Xander Bogaerts</a></span>
        <div class="comments-container">
              <div id="respond-707196">
          <div id="707196" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-707196"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-707196"></div>
    <div id="taboola-container-text-links-post-707196"></div>
  </footer>
  <!-- .entry-footer -->
</article>
  </div>
  <div id="article-loadmore">
    <div class="footer_more-link">
      <a href="/articles/6/191/1" id="load_more_articles" class="use-ajax link link_type-block">Load more</a>    </div>
  </div>
</div>
  </div>
</div>
  </div>
                </div>
            </div>

                        <aside id="nbcsports-right-rail" class="sidebar sidebar_second">
                <div class="region region-right-rail">
    <div id="block-nbcs-article-nbcs-article-rail" class="block block-nbcs-article">

    
  <div class="content">
    <div id="story-explorer-wrapper">
 <aside id="story-explorer" class="styled-scrollbar">
    <div id="story-explorer-headlines">
      <div id="article-rail-ad"></div>
       <div id="article-rail-ad"></div>

<a href="/boston-red-sox/drellich-boston-red-sox-should-get-trade-done-sooner-rather-later" class="story-explorer-item" id="headline-707291">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/18/red_sox_dave_dombrowski_071717.jpg?itok=u_voFO-1" width="656" height="369" alt="red_sox_dave_dombrowski_071717.jpg" title="Drellich: Red Sox should get a trade done sooner rather than later" /></span>
  <span class="item-headline">Drellich: Red Sox should get a trade done sooner rather than later</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500352596"></span>
</a>

<a href="/boston-red-sox/pearce-go-ahead-single-eighth-leads-toronto-blue-jays-over-boston-red-sox-4-3" class="story-explorer-item" id="headline-707266">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/17/blue_jays_steve_pearce_071717.jpg?itok=pOrbLQ5c" width="656" height="369" alt="blue_jays_steve_pearce_071717.jpg" title="Pearce go-ahead single in eighth leads Blue Jays over Red Sox, 4-3" /></span>
  <span class="item-headline">Pearce go-ahead single in eighth leads Blue Jays over Red Sox, 4-3</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500347568"></span>
</a>

<a href="/boston-red-sox/john-farrell-open-changing-boston-red-sox-slumping-lineup" class="story-explorer-item" id="headline-707196">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/17/farrell-redsox.jpg?itok=pHUfDU3y" width="656" height="369" alt="farrell-redsox.jpg" title="Farrell open to changing Red Sox lineup; has already altered rotation" /></span>
  <span class="item-headline">Farrell open to changing Red Sox lineup; has already altered rotation</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500329339"></span>
</a>

<a href="/boston-red-sox/boston-red-sox-activate-eduardo-rodriguez-dl-option-tzu-wei-lin-austin-maddox-pawtucket" class="story-explorer-item" id="headline-707166">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/17/boston-red-sox-eduardo-rodriguez-40817.jpg?itok=RcsXfPYZ" width="656" height="369" alt="boston-red-sox-eduardo-rodriguez-40817.jpg" title="Red Sox activate Rodriguez from DL, option Lin, Maddox to Pawtucket" /></span>
  <span class="item-headline">Red Sox activate Rodriguez from DL, option Lin, Maddox to Pawtucket</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500318783"></span>
</a>

<a href="/boston-red-sox/boston-red-sox-david-price-throwing-more-hard-pitches-during-run-of-success" class="story-explorer-item" id="headline-707121">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/17/red-sox-david-price-1-071717.jpg?itok=8J7be4w4" width="656" height="369" alt="red-sox-david-price-1-071717.jpg" title="He&#039;s once again a hard and fast Price . . . to great effectiveness" /></span>
  <span class="item-headline">He's once again a hard and fast Price . . . to great effectiveness</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500303721"></span>
</a>

<a href="/boston-red-sox/boston-herald-steve-buckley-thinks-boston-red-sox-will-win-american-league-eastern-division-nine-games" class="story-explorer-item" id="headline-707056">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/17/red-sox-david-price-071717.jpg?itok=kNEw0Brs" width="656" height="369" alt="red-sox-david-price-071717.jpg" title="Buckley: &#039;Still think Red Sox will win division by nine games&#039;" /></span>
  <span class="item-headline">Buckley: 'Still think Red Sox will win division by nine games'</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500290461"></span>
</a>

<a href="/boston-red-sox/boston-red-sox-beat-yankees-3-0-split-series-after-doubleheader" class="story-explorer-item" id="headline-707011">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/17/red-sox-bradley-betts-071717.jpg?itok=eNdvsOsU" width="656" height="369" alt="red-sox-bradley-betts-071717.jpg" title="Bradley&#039;s eye-popping catch helps Sox to 3-0 win, doubleheader split" /></span>
  <span class="item-headline">Bradley's eye-popping catch helps Sox to 3-0 win, doubleheader split</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500263895"></span>
</a>

<a href="/boston-red-sox/boston-red-sox-baseball-show-podcast-are-red-sox-trading-todd-frazier" class="story-explorer-item" id="headline-707006">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/16/baseball-show-pod.png?itok=_cRokSoB" width="656" height="369" alt="baseball-show-pod.png" title="Baseball Show Podcast: Are Red Sox trading for Todd Frazier?" /></span>
  <span class="item-headline">Baseball Show Podcast: Are Red Sox trading for Todd Frazier?</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500259464"></span>
</a>

<a href="/boston-red-sox/what-should-red-sox-give-todd-frazier" class="story-explorer-item" id="headline-706951">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/16/white_sox_todd_frazier_071317.jpg?itok=cmBE3Sa7" width="656" height="369" alt="white_sox_todd_frazier_071317.jpg" title="What should the Red Sox give up for Todd Frazier?" /></span>
  <span class="item-headline">What should the Red Sox give up for Todd Frazier?</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500247584"></span>
</a>

<a href="/boston-red-sox/boston-red-sox-lou-merloni-pablo-sandoval-contract-worst-sox-history-and-its-not-close" class="story-explorer-item" id="headline-706941">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/16/2017-07-16t22-46-09.966z-1280x720.jpg?itok=8I1yBXgG" width="656" height="369" alt="2017-07-16t22-46-09.966z-1280x720.jpg" title="Lou Merloni: Pablo Sandoval contract worst in Sox history and it&#039;s not close" /></span>
  <span class="item-headline">Lou Merloni: Pablo Sandoval contract worst in Sox history and it's not close</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500247269"></span>
</a>

<a href="/boston-red-sox/boston-red-sox-shut-out-new-york-yankees-game-1-doubleheader-3-0" class="story-explorer-item" id="headline-706906">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/16/red_sox_071617.jpg?itok=De3MapDS" width="656" height="369" alt="red_sox_071617.jpg" title="Red Sox shut out by Yankees in Game 1 of doubleheader, 3-0" /></span>
  <span class="item-headline">Red Sox shut out by Yankees in Game 1 of doubleheader, 3-0</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500238971"></span>
</a>

<a href="/boston-red-sox/brock-holt-activated-talked-dale-earnhardt-jr-about-long-road-recovery" class="story-explorer-item" id="headline-706891">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/16/boston-red-sox-brock-holt-infield.jpg?itok=W6hTEEAy" width="656" height="369" alt="boston-red-sox-brock-holt-infield.jpg" title="Holt, activated, talked to Dale Earnhardt Jr. about long road to recovery" /></span>
  <span class="item-headline">Holt, activated, talked to Dale Earnhardt Jr. about long road to recovery</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500225934"></span>
</a>

<a href="/boston-red-sox/yankees-top-red-sox-4-1-16th-boston-plays-under-protest" class="story-explorer-item" id="headline-706836">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/15/red_sox_yankees_071517.jpg?itok=DFKlg1EY" width="656" height="369" alt="red_sox_yankees_071517.jpg" title="Yankees top Red Sox 4-1 in 16th; Boston plays under protest" /></span>
  <span class="item-headline">Yankees top Red Sox 4-1 in 16th; Boston plays under protest</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500171738"></span>
</a>

<a href="/boston-red-sox/boston-red-sox-and-todd-frazier-chicago-white-sox-matter-price" class="story-explorer-item" id="headline-706786">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/15/todd_frazier_white_sox_071517.jpg?itok=9mL2DPBo" width="656" height="369" alt="todd_frazier_white_sox_071517.jpg" title="With Red Sox and Frazier, it&#039;s a matter of cost" /></span>
  <span class="item-headline">With Red Sox and Frazier, it's a matter of cost</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500145443"></span>
</a>

<a href="/boston-red-sox/evan-drellich-pablo-sandoval-boston-red-sox-figured-out-support-system-too-late" class="story-explorer-item" id="headline-706781">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/15/sandoval.jpg?itok=fdORy4fN" width="656" height="369" alt="sandoval.jpg" title="Drellich: Sandoval, Sox figured out support system too late" /></span>
  <span class="item-headline">Drellich: Sandoval, Sox figured out support system too late</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500144622"></span>
</a>

<a href="/boston-red-sox/ryan-red-sox-cutting-sandoval-was-inevitable-and-necessary" class="story-explorer-item" id="headline-706746">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/15/boston-red-sox-pablo-sandoval-62217.jpg?itok=EtPmqTLx" width="656" height="369" alt="boston-red-sox-pablo-sandoval-62217.jpg" title="Ryan: Red Sox cutting Sandoval was &#039;inevitable and necessary&#039;" /></span>
  <span class="item-headline">Ryan: Red Sox cutting Sandoval was 'inevitable and necessary'</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500100718"></span>
</a>

<a href="/boston-red-sox/what-are-biggest-blunders-boston-sports-history" class="story-explorer-item" id="headline-706741">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/15/2017-07-14t23-09-35.412z-1280x720.jpg?itok=kzEIIyo8" width="656" height="369" alt="2017-07-14t23-09-35.412z-1280x720.jpg" title="What are the biggest blunders in Boston sports history?" /></span>
  <span class="item-headline">What are the biggest blunders in Boston sports history?</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500100359"></span>
</a>

<a href="/boston-red-sox/john-farrell-red-sox-were-relentless-until-final-out" class="story-explorer-item" id="headline-706736">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/15/2017-07-15t02-52-11.833z-1280x720.jpg?itok=vXqrtZ_h" width="656" height="369" alt="2017-07-15t02-52-11.833z-1280x720.jpg" title="John Farrell: Red Sox were &#039;relentless until the final out&#039;" /></span>
  <span class="item-headline">John Farrell: Red Sox were 'relentless until the final out'</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500099991"></span>
</a>

<a href="/boston-red-sox/scott-makes-fixes-while-chapman-flounders-red-sox-walk-win" class="story-explorer-item" id="headline-706726">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/15/red_sox_yankees_chapman_scott_071417.jpg?itok=XImTEiLs" width="656" height="369" alt="red_sox_yankees_chapman_scott_071417.jpg" title="Scott makes fixes while Chapman flounders in Red Sox walk-off win" /></span>
  <span class="item-headline">Scott makes fixes while Chapman flounders in Red Sox walk-off win</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500096096"></span>
</a>

<a href="/boston-red-sox/chapman-walks-winning-run-boston-red-sox-beat-new-york-yankees-5-4" class="story-explorer-item" id="headline-706686">
  <span class="item-thumbnail"><img src="/sites/csnne/files/styles/article_hero_image/public/2017/07/14/red_sox_yankees_walkoff_071417.jpg?itok=teTbCnul" width="656" height="369" alt="red_sox_yankees_walkoff_071417.jpg" title="Chapman walks in winning run, Red Sox beat Yankees, 5-4" /></span>
  <span class="item-headline">Chapman walks in winning run, Red Sox beat Yankees, 5-4</span>
  <span class="item-timestamp item-add-time-ago" data-timestamp="1500088258"></span>
</a>
<div id="story-explorer-legal">
  </div>
    </div>
  </aside>
</div>
  </div>
</div>
  </div>
            </aside>
                      </div>

        </div>
        <!-- End main content -->

      </div>
      <!-- End content wrapper -->

      <!-- Start footer -->
      <footer id="nbcsports-footer">
          <div class="region region-footer">
    <div id="block-bean-dx-agency-twitter-pixel" class="block block-bean block-bean-custom-block block-type-custom-block block-type-custom-block-single">

    
  <div class="content">
    <div class="entity entity-bean bean-custom-block clearfix">

  <div class="content">
    <div class="field field-name-field-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><!-- Twitter universal website tag code -->
<script>
!function(e,t,n,s,u,a){e.twq||(s=e.twq=function(){s.exe?s.exe.apply(s,arguments):s.queue.push(arguments);
},s.version='1.1',s.queue=[],u=t.createElement(n),u.async=!0,u.src='//static.ads-twitter.com/uwt.js',
a=t.getElementsByTagName(n)[0],a.parentNode.insertBefore(u,a))}(window,document,'script');
// Insert Twitter Pixel ID and Standard Event data below
twq('init','nv9qo');
twq('track','PageView');
</script>
<!-- End Twitter universal website tag code --></div></div></div>  </div>
</div>
  </div>
</div>
<div id="block-nbcs-footer-nbcs-footer" class="block block-nbcs-footer">

    
  <div class="content">
    <div id="footer-left">
  <div id="footer-logo"></div>
  <div id="footer-social-links">
    <span id="follow-us">FOLLOW US</span>
          <a href="http://facebook.com/CSNNE" class="genericon genericon-facebook">Facebook</a>          <a href="http://twitter.com/csnne" class="genericon genericon-twitter">Twitter</a>          <a href="http://plus.google.com/+CSNNE" class="genericon genericon-googleplus">Google Plus</a>          <a href="http://instagram.com/CSNNE" class="genericon genericon-instagram">Instagram</a>      </div>
  <div id="copyright">©2017 SportsChannel New England LLC</div>
  <div id="footer-site-links">
          <a href="http://www.nbcuniversal.com">A Division of NBC Universal</a>          <a href="http://www.nbcunicareers.com/">Jobs</a>          <a href="http://www.nbcuniversal.com/privacy">Privacy Policy</a>          <a href="/term-service">Term of Service</a>          <a href="/contact">Contact Us</a>          <a href="/advertising">Advertise</a>          <a href="/live">Live FAQ</a>          <a href="http://www.nbcunicareers.com/search-results?search_type=advanced&amp;location=&amp;keywords=&amp;business=&amp;sub-business=&amp;function=&amp;job-number=34117BR">Internships</a>          <a href="/pressreleases">Press Releases</a>          <a href="/ontv">TV Listings</a>          <a href="http://info.evidon.com/pub_info/267?v=1">Ad Choices</a>      </div>
</div>
<div id="footer-right">
  <div id="footer-newsletter-link">
        <span id="newsletter-banner">GET NEWSLETTERS &amp; ALERTS</span>&#13;
    <a href="http://email.comcastsportsnet.com/csn/prefne.do" id="newsletter-link">SIGN UP</a>   </div>
</div>
  </div>
</div>
  </div>
      </footer>
      <!-- End footer -->

    </div><!-- end #outer -->
  </div><!-- end #wrapper -->
  <!-- SiteCatalyst code version: 1.7.0
Copyright 1996-2017 Adobe, Inc. -->
<script type="text/javascript" src="/sites/all/modules/custom/nbcs_sitecatalyst/js/nbcs_adobe.js?osz121"></script>
<script type="text/javascript"><!--

var nbcscontenthub="nbcs.contenthub";
s.contextData[nbcscontenthub]="News";
var nbcsteam="nbcs.team";
s.contextData[nbcsteam]="Boston Red Sox";
var nbcsleague="nbcs.league";
s.contextData[nbcsleague]="MLB";
var nbcssport="nbcs.sport";
s.contextData[nbcssport]="Baseball";
var nbcsauthor="nbcs.author";
s.contextData[nbcsauthor]="Evan Drellich";
var nbcssubfeature="nbcs.subfeature";
s.contextData[nbcssubfeature]="Boston Red Sox";
var nbcscontenttype="nbcs.contenttype";
s.contextData[nbcscontenttype]="Story";
var nbcscontentid="nbcs.contentid";
s.contextData[nbcscontentid]="707291";
var nbcscontenttitle="nbcs.contenttitle";
s.contextData[nbcscontenttitle]="Drellich: Red Sox should get a trade done sooner rather than later";
var nbcspagenumber="nbcs.pagenumber";
s.contextData[nbcspagenumber]=1;
var nbcsrelease_version="nbcs.release_version";
s.contextData[nbcsrelease_version]="1.27.5";
/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
var s_code=s.t();if(s_code)document.write(s_code)//--></script>
<script type="text/javascript"><!--
if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')
//--></script>
<noscript><img src="http://examplecom.112.2O7.net/b/ss/examplecom/1/H.20.3--NS/0/3483213" height="1" width="1" alt=""></noscript>
<!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: 1.7.0 -->
<script type="text/javascript" src="http://www.csnne.com/sites/csnne/files/js/js_0JEPx4qQCYNt7huNwmVF7GVvHooDX2gO0Ld3x8lMIPc.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
typeof(mps)=='object' && typeof(mps.writeFooter)=='function' && mps.writeFooter();
//--><!]]>
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"cf07660617","applicationID":"15907363","transactionName":"ZQNbZ0cAX0UEABdcCVxJeFBBCF5YSg0MUQNtFlhUUD5HXwAU","queueTime":0,"applicationTime":376,"atts":"SURYEQ8aTEs=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
